How It Works

System Requirements


Compatible Devices

Our courses can be viewed on both Mac and Windows computers, as well as iOS and Android mobile devices. For more information about mobile devices, see “Mobile Users” below.

Compatible Browsers

Our courses and website are compatible with most current web browsers. Minimum browser requirements: Microsoft Internet Explorer 8 or later, Microsoft Edge, Firefox, Google Chrome, Safari 7 or later, or any other browser that provides equal or greater functionality. It is important that you update your browser to the latest version in order to ensure the best possible course experience. If you are concerned about your browser’s compatibility, you may use the links below to download or update your web browser.

Please note the following about your desktop or laptop web browser:

  • Most of our pages require that JavaScript is enabled. This majority of web browsers have this enabled by default. If for some reason it has been disabled in your browser, please refer to these instructions for enabling JavaScript.
  • A few of our pages use pop-up windows, so you may be prompted to disable any pop-up blockers you have enabled in order for these to be displayed.

Mobile Users

Apple devices (including iPad and iPhone) must be running iOS 7 or later. If you are running an older version of iOS, please use these instructions for updating iOS. Courses are compatible with the Safari browser.

Android devices must be running Android OS 4.1 or later, and courses are compatible with Google Chrome.



More questions?

Contact Us

Protect Your Driving Record


Enroll Now